summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-06-04 16:05:07 +0800
committer宋文武 <iyzsong@gmail.com>2016-06-04 16:05:07 +0800
commitda3aeeb62bba0b545baf7beac641615080f9e68d (patch)
tree364c3ede9c80ac7a7349424a6ec4d17d20b8b21b
parentd79a343b91202a927f76a850be0e3db527960a21 (diff)
downloadguix-da3aeeb62bba0b545baf7beac641615080f9e68d.tar.gz
gnu: Add python-twisted and python2-twisted.
* gnu/packages/python.scm (python-twisted, python2-twisted): New variables.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 456bf3b30e..dfbf2cc916 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8982,3 +8982,30 @@ to provide a high-level synchronous API on top of the libev event loop.")
 
 (define-public python2-gevent
   (package-with-python2 python-gevent))
+
+(define-public python-twisted
+  (package
+    (name "python-twisted")
+    (version "16.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (list (pypi-uri "Twisted" version ".tar.bz2") ; 404
+                         (string-append
+                          "https://pypi.io/packages/source/T/Twisted/"
+                          "Twisted-" version ".tar.bz2")))
+              (sha256
+               (base32
+                "0ydxrp9myw1mvsz3qfzx5579y5llmqa82pxvqchgp5syczffi450"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)
+       ("python-zope-interface" ,python-zope-interface)))
+    (home-page "https://twistedmatrix.com/")
+    (synopsis "Asynchronous networking framework written in Python")
+    (description
+     "Twisted is an extensible framework for Python programming, with special
+focus on event-based network programming and multiprotocol integration.")
+    (license license:expat)))
+
+(define-public python2-twisted
+  (package-with-python2 python-twisted))