summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-22 14:30:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-12-24 10:10:39 +0100
commitdd686c0838c9685bc1307d74e61e8f2c3c5fc60a (patch)
tree0463478c1fdfc5b7b337fbffcdad4bf0794a5ab0
parentfc2448bf89c98cd42ee6b5c71d7513568000977b (diff)
downloadguix-dd686c0838c9685bc1307d74e61e8f2c3c5fc60a.tar.gz
gnu: Add Log::Report.
* gnu/packages/perl.scm (perl-log-report): New variable.
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a5175ece35..bac20ef8b4 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2795,6 +2795,29 @@ In that case, the module using the 'Optional' will also use the full
 version.")
     (license (package-license perl))))
 
+(define-public perl-log-report
+  (package
+    (name "perl-log-report")
+    (version "1.10")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/M/MA/MARKOV/"
+                                  "Log-Report-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1jjx1ari3a7ixsyan91b6n7lmjq6dy5223k3x2ah18qbxvw4caap"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-devel-globaldestruction" ,perl-devel-globaldestruction)
+       ("perl-log-report-optional" ,perl-log-report-optional)
+       ("perl-string-print" ,perl-string-print)))
+    (home-page "http://search.cpan.org/dist/Log-Report")
+    (synopsis "Get messages to users and logs")
+    (description
+     "@code{Log::Report} combines three tasks which are closely related in
+one: logging, exceptions, and translations.")
+    (license (package-license perl))))
+
 (define-public perl-list-allutils
   (package
     (name "perl-list-allutils")