summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-05-12 09:28:14 +0800
committer宋文武 <iyzsong@gmail.com>2016-05-12 09:28:14 +0800
commitde1d68a2955ab1934338bee185fdba6c8934bd6e (patch)
treee0407a148206cc5d9687559e9e44a31353246b9c
parent9f5e79675367aedd6be89e07edbc08a6e3695fab (diff)
downloadguix-de1d68a2955ab1934338bee185fdba6c8934bd6e.tar.gz
gnu: aseprite: Fix build.
* gnu/packages/game-development.scm (aseprite)[arguments]: Remove #:phases.
-rw-r--r--gnu/packages/game-development.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 86cbb2d41e..bc0051d4c6 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -374,15 +374,7 @@ etc.")
              "-DENABLE_UPDATER=0" ; no auto-updates
              (string-append "-DFREETYPE_INCLUDE_DIR="
                             (assoc-ref %build-inputs "freetype")
-                            "/include/freetype2"))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-freetype-utils
-           (lambda _
-             ;; Fix C preprocessor include directive.
-             (substitute* '("src/app/util/freetype_utils.cpp")
-               (("freetype/") ""))
-             #t)))))
+                            "/include/freetype2"))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     ;; TODO: Use a patched Allegro 4 that supports window resizing.  This