summary refs log tree commit diff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-01-04 16:25:44 +0100
committerRoel Janssen <roel@gnu.org>2018-01-04 17:11:24 +0100
commite21f347357da42c37a71c45f120c1c7a9d6fab7d (patch)
tree081d6bdb8fff33e8871ac7bbde86ba4dea50bc46
parentc8320d1032eb251cf922c7722e30044e5c135f53 (diff)
downloadguix-e21f347357da42c37a71c45f120c1c7a9d6fab7d.tar.gz
gnu: vlc: Enable libdvdread and libdvdcss support.
* gnu/packages/video.scm (libdvdread): Compile with libdvdcss support;
  (vlc): Add libdvdread as input.
-rw-r--r--gnu/packages/video.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2d638abfe8..77a82bb9db 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -22,6 +22,7 @@
 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1357,6 +1358,12 @@ players, like VLC or MPlayer.")
                (base32
                 "0ayqiq0psq18rcp6f5pz82sxsq66v0kwv0y55dbrcg68plnxy71j"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags '("--with-libdvdcss=yes")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     `(("libdvdcss" ,libdvdcss)))
     (home-page "http://dvdnav.mplayerhq.hu/")
     (synopsis "Library for reading video DVDs")
     (description