summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-12-23 00:39:24 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-12-23 19:45:55 +0100
commite4d6746f8ea8c2cf02187031df0214fc73e603cc (patch)
tree7defce675ef39359bb8dd8b6c41be0c5728482a8
parent89f51a9dacbeded0f9b2fb1e79c1d27bdbc3e83e (diff)
downloadguix-e4d6746f8ea8c2cf02187031df0214fc73e603cc.tar.gz
gnu: igt-gpu-tools: Fetch from upstream git repository.
* gnu/packages/admin.scm (igt-gpu-tools)[source]: Use GIT-FETCH and
GIT-FILE-NAME.  Fetch from the master repository, not the mirror.
-rw-r--r--gnu/packages/admin.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9cf83302e2..a5f5d7f966 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2804,14 +2804,15 @@ buffers.")
   (package
     (name "igt-gpu-tools")
     (version "1.23")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://cgit.freedesktop.org/xorg/app/"
-                                  "intel-gpu-tools/snapshot/"
-                                  "igt-gpu-tools-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0vzv2i4jfv2pkbqby5k3ap9pzidkmajwqmg3s7wnv8i1h33775iq"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.freedesktop.org/drm/igt-gpu-tools.git")
+             (commit (string-append "igt-gpu-tools-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ra0l7917434z02gfzlh61gx5asw051m1q7h1i1gzhh25wba1hz1"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f              ; many of the tests try to load kernel modules