summary refs log tree commit diff
diff options
context:
space:
mode:
authorAmade Nemes <nemesamade@gmail.com>2023-03-05 18:43:28 +0100
committerChristopher Baines <mail@cbaines.net>2023-03-13 20:32:43 +0000
commite5cc1fffba18926fc11379250204eb362baee862 (patch)
treef2c59c3f66d3b9858edfef1c5489fbdf811693f0
parentc2dbcbefe25c2059062a822dbff9ad2726257b3b (diff)
downloadguix-e5cc1fffba18926fc11379250204eb362baee862.tar.gz
gnu: python-bibtexparser: Update to 1.4.0.
* gnu/packages/python-xyz.scm (python-bibtexparser): Update to 1.4.0.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9daacb9777..e52579ede4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -133,6 +133,7 @@
 ;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
 ;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2023 Gabriel Wicki <gabriel@erlikon.ch>
+;;; Copyright © 2023 Amade Nemes <nemesamade@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25148,19 +25149,16 @@ for manual interpretation.")
 (define-public python-bibtexparser
   (package
     (name "python-bibtexparser")
-    (version "1.1.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "bibtexparser" version))
-       (sha256
-        (base32
-         "0zwhfkrzf3n5847dbnfng92k7ak199l9v6x6ax3dgdidfpm6d2fz"))))
+    (version "1.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "bibtexparser" version))
+              (sha256
+               (base32
+                "1rmc178qqb8814v3pcfv4qgl8rxmkd11d56limkqmi776jyf4z6a"))))
     (build-system python-build-system)
-    (propagated-inputs
-     (list python-pyparsing))
-    (native-inputs
-     (list python-future))
+    (propagated-inputs (list python-pyparsing))
+    (native-inputs (list python-future))
     (home-page "https://github.com/sciunto-org/python-bibtexparser")
     (synopsis "Python library to parse BibTeX files")
     (description "BibtexParser is a Python library to parse BibTeX files.")