summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-07-15 18:24:10 +0200
committerLudovic Courtès <ludo@gnu.org>2019-07-15 18:27:23 +0200
commite8fc56a3d22dfea764725574a7c57fa9a5f16519 (patch)
tree134976e2fb224e07ef508ada7da84f45854af871
parent6f8eb9f1d8bc8660349658602698db36965bba5d (diff)
downloadguix-e8fc56a3d22dfea764725574a7c57fa9a5f16519.tar.gz
gnu: open-zwave: Use the bundled TinyXML.
* gnu/packages/zwave.scm (open-zwave)[source](snippet): Remove code to
use our own TinyXML.
[inputs]: Remove TINYXML.
-rw-r--r--gnu/packages/zwave.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/zwave.scm b/gnu/packages/zwave.scm
index f07367d264..2019ec32df 100644
--- a/gnu/packages/zwave.scm
+++ b/gnu/packages/zwave.scm
@@ -51,11 +51,9 @@
                     (("\\$\\(LDFLAGS\\)")
                      "$(LDFLAGS) -Wl,-rpath=$(PREFIX)/lib"))
 
-                  ;; Delete the bundled TinyXML.
-                  (delete-file-recursively "cpp/tinyxml")
-                  (substitute* "cpp/build/Makefile"
-                    (("LIBS \\+= -ludev")
-                     "LIBS += -ludev -ltinyxml "))
+                  ;; XXX: There's a bundled TinyXML under cpp/tinyxml.  Keep
+                  ;; it because using our own TinyXML leads to double-free
+                  ;; down the road.
 
                   ;; Delete the bundled HIDAPI.
                   (delete-file-recursively "cpp/hidapi")
@@ -80,8 +78,7 @@
                      ("pkg-config" ,pkg-config)
                      ("perl" ,perl)               ;for tests
                      ("perl-xml-simple" ,perl-xml-simple)))
-    (inputs `(("tinyxml" ,tinyxml)
-              ("hidapi" ,hidapi)
+    (inputs `(("hidapi" ,hidapi)
               ("eudev" ,eudev)))
     (home-page "http://www.openzwave.net/")
     (synopsis "Access Z-Wave devices from C++ programs")