summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-17 10:00:14 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:46 +0530
commiteef1afbc65b7befb55e66fe6f59bf20413268dc8 (patch)
treef270139cb2cdccaed849223262db5b3694b760c5
parent3688b52426375534b9a4ef38910b58563371189c (diff)
downloadguix-eef1afbc65b7befb55e66fe6f59bf20413268dc8.tar.gz
gnu: Add rust-syn-test-suite-0.
* gnu/packages/crates-io.scm (rust-syn-test-suite-0): New variable.
-rw-r--r--gnu/packages/crates-io.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c7215ad6fa..9d14beba83 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -24155,6 +24155,24 @@ cryptographic implementations.")
     (description "Custom derive for sval.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-syn-test-suite-0
+  (package
+    (name "rust-syn-test-suite")
+    (version "0.0.0+test")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "syn-test-suite" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1d9ffrbgci1qjdcpvgrsg3sh24qdsdh66zcsvn5prrk05ycn3mm0"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/dtolnay/syn")
+    (synopsis "Test suite of the syn crate")
+    (description "This package provides the test suite of the syn crate.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-syn-1
   (package
     (name "rust-syn")