summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-08-20 13:22:29 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-08-20 13:22:29 +0300
commitf0499100a62e0b36ea31ad46021d30a9868b71ea (patch)
treef62211770c7a34bb8c9a56e307c5f964ceae763b
parentd7284b6a9a0ebeee070c5e7bd6532519136cd0c5 (diff)
downloadguix-f0499100a62e0b36ea31ad46021d30a9868b71ea.tar.gz
gnu: python-2: Update to 2.7.12.
* gnu/packages/python.scm (python-2): Update to 2.7.12.
[arguments]: Move the mips64el failing test ...
[source]: ... to the snippet here.
-rw-r--r--gnu/packages/python.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b96f1c4d72..67494234c9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -105,7 +105,7 @@
 (define-public python-2.7
   (package
     (name "python")
-    (version "2.7.11")
+    (version "2.7.12")
     (source
      (origin
       (method url-fetch)
@@ -113,7 +113,7 @@
                           version "/Python-" version ".tar.xz"))
       (sha256
        (base32
-        "0iiz844riiznsyhhyy962710pz228gmhv8qi3yk4w4jhmx2lqawn"))
+        "0y7rl603vmwlxm6ilkhc51rx2mfj14ckcz40xxgs0ljnvlhp30yp"))
       (patches (search-patches "python-2.7-search-paths.patch"
                                "python-2-deterministic-build-info.patch"
                                "python-2.7-source-date-epoch.patch"))
@@ -125,6 +125,7 @@
        '(begin
           (for-each delete-file
                     '("Lib/test/test_compileall.py"
+                      "Lib/test/test_ctypes.py" ; fails on mips64el
                       "Lib/test/test_distutils.py"
                       "Lib/test/test_import.py"
                       "Lib/test/test_shutil.py"
@@ -200,13 +201,6 @@
            (lambda _
              ;; 'Lib/test/test_site.py' needs a valid $HOME
              (setenv "HOME" (getcwd))
-             ,@(if (string-prefix? "mips64el" (%current-system))
-
-                   ;; XXX: The following test fails on mips64el.
-                   '((false-if-exception
-                      (delete-file "Lib/test/test_ctypes.py")))
-
-                   '())
              #t))
           (add-after
            'unpack 'set-source-file-times-to-1980
@@ -288,7 +282,7 @@
      (list (search-path-specification
             (variable "PYTHONPATH")
             (files '("lib/python2.7/site-packages")))))
-    (home-page "http://python.org")
+    (home-page "https://www.python.org")
     (synopsis "High-level, dynamically-typed programming language")
     (description
      "Python is a remarkably powerful dynamic programming language that