summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-11-23 12:05:39 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-11-23 13:28:19 +0100
commitf14c6af5dc0d4924a44edb133cee37b42a935bc6 (patch)
tree960c9c89f6d26333fa63758be194a373d79ca113
parent72fbbca80dea448baabbb5b820992373647d66f0 (diff)
downloadguix-f14c6af5dc0d4924a44edb133cee37b42a935bc6.tar.gz
gnu: Add djvusmooth.
* gnu/packages/djvu.scm (djvusmooth): New variable.
-rw-r--r--gnu/packages/djvu.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/djvu.scm b/gnu/packages/djvu.scm
index 90db1a2d42..65d712819c 100644
--- a/gnu/packages/djvu.scm
+++ b/gnu/packages/djvu.scm
@@ -26,6 +26,7 @@
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages check)
@@ -41,7 +42,9 @@
   #:use-module (gnu packages pdf)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
+  #:use-module (gnu packages wxwidgets)
   #:use-module (gnu packages xorg))
 
 (define-public djvulibre
@@ -272,3 +275,36 @@ encoder/decoder.  It doesn't support colors or grayscales, just black
 and white.")
     (home-page "https://sourceforge.net/projects/minidjvu/")
     (license license:gpl2)))
+
+(define-public djvusmooth
+  (package
+    (name "djvusmooth")
+    (version "0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/jwilk/djvusmooth/releases/download/" version
+             "/djvusmooth-" version ".tar.gz"))
+       (sha256
+        (base32 "0z403cklvxzz0qaczgv83ax0nknrd9h8micp04j9kjfdxk2sgval"))))
+    (build-system python-build-system)
+    (inputs
+     `(("djvulibre" ,djvulibre)
+       ("python2-djvulibre" ,python2-djvulibre)
+       ("python2-subprocess32" ,python2-subprocess32)
+       ("python2-wxpython" ,python2-wxpython)))
+    (arguments
+     `(#:python ,python-2))
+    (synopsis "Graphical editor for DjVu documents")
+    (description
+     "@code{djvusmooth} is a graphical editor for DjVu_ documents.
+It is able to:
+@itemize
+@item edit document metadata,
+@item edit document outline (bookmarks),
+@item add, remove or edit hyperlinks,
+@item correct occasional errors in the hidden text layer.
+@end itemize\n")
+    (home-page "https://jwilk.net/software/djvusmooth")
+    (license license:gpl2)))