summary refs log tree commit diff
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-10-01 08:49:21 -0400
committerLeo Famulari <leo@famulari.name>2018-10-01 09:08:10 -0400
commitf359b115c74c9c5fdf482528a0480ed40f5a2446 (patch)
tree6b2f9e7cd8214eb714200cc901bdd63457c3c29c
parent5ec20676d75a25c9163c6067d2e3eece84d08c2b (diff)
downloadguix-f359b115c74c9c5fdf482528a0480ed40f5a2446.tar.gz
gnu: Add r-mhsmm.
* gnu/packages/cran.scm (r-mhsmm): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a38c907cd5..82984548a2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5946,3 +5946,26 @@ model.  It also provides multiple functions to preprocess the accelerometer data
 previous to the missing data imputation.  These include detecting the wearing
 and the non-wearing time, selecting valid days and subjects, and creating plots.")
     (license license:gpl2+)))
+
+(define-public r-mhsmm
+  (package
+    (name "r-mhsmm")
+    (version "0.4.16")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "mhsmm" version))
+       (sha256
+        (base32 "009dj0zkj1zry7jr9hf4cknb686z50a2l967if64xm0dvjmp7dgs"))))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-mvtnorm" ,r-mvtnorm)))
+    (home-page "https://github.com/jaredo/mhsmm/")
+    (synopsis "Inference for hidden Markov and semi-Markov models")
+    (description
+     "The @code{r-mhsmm} package implements estimation and prediction methods for
+hidden Markov and semi-Markov models for multiple observation sequences.  Such
+techniques are of interest when observed data is thought to be dependent on some
+unobserved (or hidden) state.  Also, this package is suitable for equidistant
+time series data, with multivariate and/or missing data.  Allows user defined
+emission distributions.")
+    (license license:gpl2+)))