summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 17:00:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:39 +0200
commitf4e9fd923facffa2b952b8de16e73bb6d1bbb75a (patch)
tree95c794d22600132a158c10b54228cdf9819823d8
parent63cb61255cc21bd68d1c9a30bf946b53748ab275 (diff)
downloadguix-f4e9fd923facffa2b952b8de16e73bb6d1bbb75a.tar.gz
gnu: Add texlive-yhmath.
* gnu/packages/tex.scm (texlive-yhmath): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5e1c6c97e9..7a19335f51 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6943,6 +6943,32 @@ structural formulas in a way that reflects their structure.  The package
 provides three output modes: LaTeX, PostScript and PDF.")
     (license license:lppl1.3+)))
 
+(define-public texlive-yhmath
+  (package
+    (name "texlive-yhmath")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/yhmath/"
+                   "fonts/map/dvips/yhmath/"
+                   "fonts/source/public/yhmath/"
+                   "fonts/tfm/public/yhmath/"
+                   "fonts/type1/public/yhmath/"
+                   "fonts/vf/public/yhmath/"
+                   "source/fonts/yhmath/"
+                   "tex/latex/yhmath/")
+             (base32
+              "0blzyr94d7ajb639j7bfnrpn52wicwfqwyba38hgh6s9hgx071cv")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (native-inputs (list texlive-metafont))
+    (home-page "https://ctan.org/pkg/yhmath")
+    (synopsis "Extended maths fonts for LaTeX")
+    (description
+     "The @code{yhmath} bundle contains fonts (in Metafont and type 1 format)
+and a LaTeX package for using them.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")