summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-01 09:48:11 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-01 13:59:58 +0200
commitf5480572d0e1c8dffce72a6e393cae937d6b2d3d (patch)
tree876850aaf902d1fafe89d81a67fd57d26ec662dc
parentdbeaf8f203fe26d3bcac1fcb0bb566ea8c4523ea (diff)
downloadguix-f5480572d0e1c8dffce72a6e393cae937d6b2d3d.tar.gz
gnu: wicd: Update to 1.7.4.
* gnu/packages/wicd.scm (wicd): Update to 1.7.4.
[source]: Remove 'wicd-template-instantiation.patch'.
* gnu/packages/patches/wicd-template-instantiation.patch: Remove.
* gnu-system.am (dist_patch_DATA): Remove it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/wicd-template-instantiation.patch29
-rw-r--r--gnu/packages/wicd.scm7
3 files changed, 3 insertions, 34 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 3e81f73196..1e730d96da 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -780,7 +780,6 @@ dist_patch_DATA =						\
   gnu/packages/patches/weex-vacopy.patch			\
   gnu/packages/patches/wicd-bitrate-none-fix.patch		\
   gnu/packages/patches/wicd-get-selected-profile-fix.patch	\
-  gnu/packages/patches/wicd-template-instantiation.patch	\
   gnu/packages/patches/wicd-urwid-1.3.patch			\
   gnu/packages/patches/wmctrl-64-fix.patch			\
   gnu/packages/patches/wpa-supplicant-CVE-2015-5310.patch	\
diff --git a/gnu/packages/patches/wicd-template-instantiation.patch b/gnu/packages/patches/wicd-template-instantiation.patch
deleted file mode 100644
index 16d8fa6e1d..0000000000
--- a/gnu/packages/patches/wicd-template-instantiation.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Wicd 1.7.3 fails to instantiate template lines that have several
-variable references.  For instance, the line:
-
-  wep_key$_KEY_INDEX=$_KEY
-
-which is found in in the 'wep-hex' template, expands to these two
-lines:
-
-  wep_key0=$_KEY
-  wep_key0=123456789ab
-
-This patch fixes that by only emitting the fully substituted line.
-
-Patch by Ludovic Courtès <ludo@gnu.org>.
-
---- a/wicd/misc.py	2012-11-17 00:07:08 +0000
-+++ b/wicd/misc.py	2015-05-09 11:22:37 +0000
-@@ -321,11 +321,11 @@ def ParseEncryption(network):
-                                 rep_val = '0'
-                         if rep_val:
-                             line = line.replace("$_%s" % cur_val, str(rep_val))
--                            config_file = ''.join([config_file, line])
-                         else:
-                             print "Ignoring template line: '%s'" % line
-                     else:
-                         print "Weird parsing error occurred"
-+                config_file = ''.join([config_file, line])
-             else:  # Just a regular entry.
-                 config_file = ''.join([config_file, line])
diff --git a/gnu/packages/wicd.scm b/gnu/packages/wicd.scm
index cad078e061..ad3aa58cdb 100644
--- a/gnu/packages/wicd.scm
+++ b/gnu/packages/wicd.scm
@@ -36,7 +36,7 @@
 (define-public wicd
   (package
     (name "wicd")
-    (version "1.7.3")
+    (version "1.7.4")
     (source
      (origin
        (method url-fetch)
@@ -44,12 +44,11 @@
                            (version-major+minor version) "/" version
                            "/+download/wicd-" version ".tar.gz"))
        (sha256
-        (base32 "00c4rq753bhg64rv1v9yl834ssq7igyy7cz3swp287b5n5bqiqwi"))
+        (base32 "0qpbwwsrqdp40mm3a8djpn2d055rxxspdhwijwsdnws700a9d637"))
        (patches (map search-patch
                      '("wicd-bitrate-none-fix.patch"
                        "wicd-get-selected-profile-fix.patch"
-                       "wicd-urwid-1.3.patch"
-                       "wicd-template-instantiation.patch")))))
+                       "wicd-urwid-1.3.patch")))))
     (build-system python-build-system)
     (native-inputs `(("gettext" ,gnu-gettext)))
     (inputs `(("dbus-glib" ,dbus-glib)