summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-14 10:38:26 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-14 10:40:21 +0100
commitf6c1ef180459a525c1b38a5a7c37fec3cfb45ab9 (patch)
tree8b4433ecaa7124abbb6c09814b6af516afcbfe10
parentfb08c4fedc33bb8b7d8c89314b8e4da870d85438 (diff)
downloadguix-f6c1ef180459a525c1b38a5a7c37fec3cfb45ab9.tar.gz
gnu: python-fixtures: Fix test suite.
* gnu/packages/python.scm (python-fixtures, python2-fixtures): Replace 'check'
  with custom phase.
  [native-inputs]: Add python-mock.
-rw-r--r--gnu/packages/python.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 080d3fccc9..ceb4896d34 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2068,10 +2068,18 @@ from git information.
         (base32
          "0djxvdwm8s60dbfn7bhf40x6g818p3b3mlwijm1c3bqg7msn271y"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (zero? (system* "python" "-m" "testtools.run"
+                             "fixtures.test_suite")))))))
     (propagated-inputs
      `(("python-six" ,python-six)))
     (native-inputs
-     `(("python-pbr-minimal" ,python-pbr-minimal)
+     `(("python-mock" ,python-mock)
+       ("python-pbr-minimal" ,python-pbr-minimal)
        ("python-testtools" ,python-testtools)))
     (home-page "https://launchpad.net/python-fixtures")
     (synopsis "Python test fixture library")