summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-03-19 00:22:56 +0530
committerMarius Bakke <mbakke@fastmail.com>2017-03-20 00:40:32 +0100
commitf75b1400ee80f2f15337bbf9d7cd6db83532de65 (patch)
treecb120e26283f3e5c902dd15a49fcc71c6f6cd47b
parent315944a39334069e0c3cefdb131721ecbc6baa7d (diff)
downloadguix-f75b1400ee80f2f15337bbf9d7cd6db83532de65.tar.gz
gnu: obnam: Enable tests.
* gnu/packages/backup.scm (obnam)[arguments]: Replace 'check' phase with
  custom function.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/backup.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 97ab70e651..7e9ae18f30 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -644,7 +644,23 @@ NTFS volumes using @code{ntfs-3g}, preserving NTFS-specific attributes.")
          "0qlipsq50hca71zc0dp1mg9zs12qm0sbblw7qfzl0hj6mk2rv1by"))))
     (build-system python-build-system)
     (arguments
-     `(#:python ,python-2))
+     `(#:python ,python-2
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'check
+                  (lambda _
+                    (substitute* "obnamlib/vfs_local_tests.py"
+                      ;; Check for the nobody user instead of root
+                      (("self.fs.get_username\\(0\\), 'root'")
+                       "self.fs.get_username(65534), 'nobody'")
+                      ;; Disable tests checking for root group
+                      (("self.fs.get_groupname\\(0\\)") "'root'"))
+                    (substitute* "obnamlib/vfs_local.py"
+                      ;; Don't cover get_groupname function
+                      (("def get_groupname\\(self, gid\\):")
+                       "def get_groupname(self, gid):  # pragma: no cover"))
+                    ;; Can't run network tests
+                    (zero? (system* "./check" "--unit-tests")))))))
     (inputs
      `(("python2-cliapp" ,python2-cliapp)
        ("python2-larch" ,python2-larch)
@@ -652,6 +668,12 @@ NTFS volumes using @code{ntfs-3g}, preserving NTFS-specific attributes.")
        ("python2-pyaml" ,python2-pyaml)
        ("python2-tracing" ,python2-tracing)
        ("python2-ttystatus" ,python2-ttystatus)))
+    (native-inputs
+     `(("gnupg" ,gnupg)
+       ("python2-coverage" ,python2-coverage)
+       ("python2-coverage-test-runner" ,python2-coverage-test-runner)
+       ("python2-pep8" ,python2-pep8)
+       ("python2-pylint" ,python2-pylint)))
     (home-page "https://obnam.org/")
     (synopsis "Easy and secure backup program")
     (description "Obnam is an easy, secure backup program.  Features