summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2015-12-07 16:22:39 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-02-02 09:24:17 -0500
commitf861b8b8e02a6813e264271c2cb70076105cb356 (patch)
treecb11e69d8714f36602a8a1885ca60d9f9a6a4c13
parent935fcd5cf625046f707f18f2992717e63c7aa412 (diff)
downloadguix-f861b8b8e02a6813e264271c2cb70076105cb356.tar.gz
gnu: Add awscli.
* gnu/packages/python.scm (awscli): New variable.
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 463b9baa70..c4d8953ff5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7410,3 +7410,34 @@ interface to the Amazon Web Services (AWS) API.")
 
 (define-public python2-botocore
   (package-with-python2 python-botocore))
+
+(define-public awscli
+  (package
+   (name "awscli")
+   (version "1.9.17")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append
+           "https://pypi.python.org/packages/source/a/awscli/awscli-"
+           version ".tar.gz"))
+     (sha256
+      (base32
+       "1nj7jqvlpq57hfhby1njsbf8303gapa3njc4dramr6p3ffzvfi2i"))))
+   (build-system python-build-system)
+   (inputs
+    `(("python-colorama" ,python-colorama)
+      ("python-docutils" ,python-docutils)
+      ("python-mock" ,python-mock)
+      ("python-nose" ,python-nose)
+      ("python-rsa" ,python-rsa)
+      ("python-setuptools" ,python-setuptools)
+      ("python-sphinx" ,python-sphinx)
+      ("python-tox" ,python-tox)
+      ("python-wheel" ,python-wheel)
+      ("python-botocore" ,python-botocore)))
+   (home-page "http://aws.amazon.com/cli/")
+   (synopsis "Command line client for AWS")
+   (description "AWS CLI provides a unified command line interface to the
+Amazon Web Services (AWS) API.")
+   (license asl2.0)))