summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-08-19 16:11:21 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-19 16:43:37 +0200
commitf87c1107d60372acc5ff627324e9fdd36278daa3 (patch)
tree9c863369c72be792162ecaca5d38553cda7d756b
parent1cd5f1776da210b1d2dc0594de3597881d0e0231 (diff)
downloadguix-f87c1107d60372acc5ff627324e9fdd36278daa3.tar.gz
gnu: perl: Work around more "dotless @INC" build issues.
* gnu/packages/perl.scm (perl-hash-fieldhash,
  perl-string-camelcase)[arguments]: Add 'set-perl-search-path' phase.
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 2baf09e943..e6138fcc98 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3432,6 +3432,16 @@ which are tied to the scope exit.")
         (base32
          "1wg8nzczfxif55j2nbymbhyd25pjy7dqs4bvd6jrcds3ll3mflaw"))))
     (build-system perl-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'set-perl-search-path
+           (lambda _
+             ;; Work around "dotless @INC" build failure.
+             (setenv "PERL5LIB"
+                     (string-append (getcwd) ":"
+                                    (getenv "PERL5LIB")))
+             #t)))))
     (native-inputs
      `(("perl-module-build" ,perl-module-build)
        ("perl-test-leaktrace" ,perl-test-leaktrace)))
@@ -6087,6 +6097,16 @@ run from within a source-controlled directory.")
         (base32
          "17kh8nap2z5g5rqcvw0m7mvbai7wr7h0al39w8l827zhqad8ss42"))))
     (build-system perl-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'set-perl-search-path
+           (lambda _
+             ;; Work around "dotless @INC" build failure.
+             (setenv "PERL5LIB"
+                     (string-append (getcwd) ":"
+                                    (getenv "PERL5LIB")))
+             #t)))))
     (home-page "http://search.cpan.org/dist/String-CamelCase")
     (synopsis "Camelcase and de-camelcase")
     (description "This module may be used to convert from under_score text to