summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-23 00:36:38 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-23 00:52:42 -0500
commitf9ec89f444906371dc058f202182b670e1ee4785 (patch)
tree203af88f50337244122c90df471c42df37e7e1b4
parentb93a32977e591604d36350debaf6a4dd9aaf5371 (diff)
downloadguix-f9ec89f444906371dc058f202182b670e1ee4785.tar.gz
gnu: Add srfi-64-driver.
* gnu/packages/guile-xyz.scm (srfi-64-driver): New variable.
-rw-r--r--gnu/packages/guile-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 1e676566ac..558fa4c1b4 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -22,6 +22,7 @@
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2019 swedebugia <swedebugia@riseup.net>
 ;;; Copyright © 2019 Amar Singh <nly@disroot.org>
+;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2660,3 +2661,31 @@ anything other than straight complex DFTs.")
       ;; TODO: This might actually be LGPLv3+
       ;; See https://github.com/lloda/guile-ffi-fftw/issues/1
       (license license:gpl3+))))
+
+(define-public srfi-64-driver
+  (package
+    (name "srfi-64-driver")
+    (version "0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://files.ngyro.com/srfi-64-driver/"
+                                  "srfi-64-driver-" version ".tar.gz"))
+              (sha256
+               (base32
+                "188b6mb7sjjg0a8zldikinglf40ky8mg8rwh5768gjmch6gkk3ph"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'build))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("guile" ,guile-2.2)))
+    (home-page "https://ngyro.com/software/srfi-64-driver.html")
+    (synopsis "Automake test driver for SRFI 64 test suites")
+    (description "This package provides an Automake test driver that can
+run SRFI 64 test suites.  It gives Automake insight into the individual
+tests being run, resulting clearer and more specific output.")
+    (license license:gpl3+)))