summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-09-13 18:39:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-09-13 18:40:30 +0300
commitfade67ab756602bdeba508fbffa0e35234b58b9c (patch)
treec2b57c166176fe3a581baad819b80616acb03328
parent060366f6b311ee3e1a57290bb6a7785417e019b7 (diff)
downloadguix-fade67ab756602bdeba508fbffa0e35234b58b9c.tar.gz
gnu: retroarch: Use shared zlib.
* gnu/packages/emulators.scm (retroarch)[arguments]: In custom
'configure phase, use our zlib instead of vendor's zlib.
-rw-r--r--gnu/packages/emulators.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index e02339af62..f21c322814 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1079,6 +1079,11 @@ emulation community.  It provides highly accurate emulation.")
                  (("libvulkan.so") (string-append vulkan "/lib/libvulkan.so")))
                (substitute* "qb/qb.libs.sh"
                  (("/bin/true") (which "true")))
+               ;; Use shared zlib.
+               (substitute* '("libretro-common/file/archive_file_zlib.c"
+                              "libretro-common/streams/trans_stream_zlib.c"
+                              "network/httpserver/httpserver.c")
+                 (("<compat/zlib.h>") "<zlib.h>"))
                ;; The configure script does not yet accept the extra arguments
                ;; (like ‘CONFIG_SHELL=’) passed by the default configure phase.
                (zero? (system*