summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-27 12:44:19 +0100
committerChristopher Baines <mail@cbaines.net>2023-07-10 08:25:59 +0100
commitfc3aa9f6027fdda2cf91f6bcaed46bb3fe7857e6 (patch)
tree3017aa91e1c156356e9fbc87504e9abc6df1bb5c
parentde33bed5c4fc0c951030ed502e1985996f7561c6 (diff)
downloadguix-fc3aa9f6027fdda2cf91f6bcaed46bb3fe7857e6.tar.gz
gnu: Add ruby-http-accept-1.
* gnu/packages/ruby.scm (ruby-http-accept-1): New variable.
-rw-r--r--gnu/packages/ruby.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a775a97c46..f274676752 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -11234,6 +11234,20 @@ HTTP headers.")
     (home-page "https://github.com/socketry/http-accept")
     (license license:expat)))
 
+(define-public ruby-http-accept-1
+  (package
+    (inherit ruby-http-accept)
+    (version "1.7.0")
+    (source (origin
+              (method git-fetch)        ;for the tests
+              (uri (git-reference
+                    (url "https://github.com/ioquatix/http-accept")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name "ruby-http-accept" version))
+              (sha256
+               (base32
+                "1hnqmqpa135s3xgcvv30qzqm8zp88my1aj05m72d2q9cvc31g92z"))))))
+
 (define-public ruby-http-cookie
   (package
     (name "ruby-http-cookie")