summary refs log tree commit diff
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2021-01-19 12:02:38 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-20 22:29:15 +0100
commitfc781578588436a68ad0e5afd9dad994c60e6a49 (patch)
tree11aab953872389cad8cc0298731685bfee96d6db
parent8f59a9fb6d11c1a5ee178ebebc977ca442f6893b (diff)
downloadguix-fc781578588436a68ad0e5afd9dad994c60e6a49.tar.gz
gnu: Add julia-inifile.
* gnu/packages/julia-xyz.scm (julia-inifile): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 6021a6ff7a..738060f865 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -148,6 +148,26 @@ scaled by a constant factor.  Consequently, they have a fixed number of
 digits (bits) after the decimal (radix) point.")
     (license license:expat)))
 
+(define-public julia-inifile
+  (package
+    (name "julia-inifile")
+    (version "0.5.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaIO/IniFile.jl")
+             (commit "8ba59958495fa276d6489d2c3903e765d75e0bc0")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "11h6f99jpbg729lplw841m68jprka7q3n8yw390bndlmcdsjabpd"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/JuliaIO/IniFile.jl")
+    (synopsis "Reading Windows-style INI files")
+    (description "This is a Julia package that defines an IniFile type that
+allows to interface with @file{.ini} files.")
+    (license license:expat)))
+
 (define-public julia-jllwrappers
   (package
     (name "julia-jllwrappers")