summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-07 10:45:40 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-08 19:32:45 +0200
commitfcac44c01253a723f4fec0e83178a553f9992a12 (patch)
treec3f4e4fa8a2b9f1f9043db901c04232af2b2247c
parent513f6c27866eef8ab3b3b439d93e6bfa2b7c4b53 (diff)
downloadguix-fcac44c01253a723f4fec0e83178a553f9992a12.tar.gz
gnu: sbcl-slime-swank: Remove gawk reference from closure.
* gnu/packages/lisp-xyz.scm (sbcl-slime-swank)[source]: Delete the 'doc' folder.

This takes the closure size from 159 MiB down to 156 MiB.
-rw-r--r--gnu/packages/lisp-xyz.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0ec698b5a4..71c0c586d7 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2292,7 +2292,14 @@ writing code that contains string literals that contain code themselves.")
              (url "https://github.com/slime/slime/")
              (commit (string-append "v" version))))
        (sha256
-        (base32 "1s5mbljlz22pb90gwbd380nighkz6gdxl77hc08gri7wwr5gy5n2"))))
+        (base32 "1s5mbljlz22pb90gwbd380nighkz6gdxl77hc08gri7wwr5gy5n2"))
+       (modules '((guix build utils)))
+         (snippet
+          ;; The doc folder drags `gawk' into the closure.  Doc is already
+          ;; provided by emacs-slime.
+          `(begin
+             (delete-file-recursively "doc")
+             #t))))
     (build-system asdf-build-system/sbcl)
     (arguments
      '(#:asd-systems '("swank")))