summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-30 02:00:00 +0200
commitfdc07212539eb2471cd5c67e42067b6fb4851db4 (patch)
tree07990c83249fb151b1c76bb7d2b53d06b98a2b03
parenta34c1c9c189be0610c7304a2348bfc504e7d2271 (diff)
downloadguix-fdc07212539eb2471cd5c67e42067b6fb4851db4.tar.gz
gnu: glirc: Install man page and README.md.
* gnu/packages/irc.scm (glirc)[arguments]:
Add a new 'install-extra-documentation phase.
-rw-r--r--gnu/packages/irc.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 262709f88a..7c6f33889d 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -107,6 +107,19 @@
      (sha256
       (base32 "0jaywb43jfv6kzyz540k02mxdgw1shc6hn7kia21alssszkilh4r"))))
   (build-system haskell-build-system)
+  (arguments
+   (list
+    #:phases
+    #~(modify-phases %standard-phases
+      (add-after 'install 'install-extra-documentation
+        (lambda _
+          (install-file "glirc.1"
+                        (string-append #$output "/share/man/man1"))
+          ;; The man page is very terse and punts to the GitHub wiki for real
+          ;; information.  Some of that is also in the README, so install it.
+          (install-file "README.md"
+                        (string-append #$output "/share/doc/"
+                                       #$name "-" #$version)))))))
   (native-inputs
    (list ghc-hunit))
   (inputs