summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-04-17 00:11:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-18 11:23:47 -0400
commitff8fd739274e12113867b0d9742318465f2993c7 (patch)
tree5ae825883a0efeaaa08a7e36a8bd1a9b3235bcd0
parenta8e17eb8e53b58e2298217f092e60e79d63a40dd (diff)
downloadguix-ff8fd739274e12113867b0d9742318465f2993c7.tar.gz
gnu: samba: Update to 4.18.1 [security fixes].
Fixes CVE-2023-0922 and CVE-2023-0614.

* gnu/packages/samba.scm (samba): Update to 4.18.1.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/samba.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 57562b3b7a..1e9c64f3cc 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -333,16 +333,14 @@ Desktops into Active Directory environments using the winbind daemon.")
 (define samba/security-fixes
   (package
     (inherit samba/pinned)
-    ;; This is 4.15.13, but we need to trim the store file name to have
-    ;; the same length as the one we are grafting above.
-    (version "4.15.A")
+    (version "4.18.1")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://download.samba.org/pub/samba/stable/"
-                           "samba-4.15.13.tar.gz"))
+                            "samba-" version ".tar.gz"))
        (sha256
-        (base32 "0s29vzn5f42vjhx6h25c7v67n14ymqxn8glqa97d0rajd99y64n4"))))))
+        (base32 "03ncp49pfpzjla205y3xpb9iy61dz4pryyrvyz26422a4hpsmpnf"))))))
 
 (define-public talloc
   (package