summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2022-07-07 10:08:38 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2022-07-08 19:32:44 +0200
commitffc6e0a391b76fc96b4311081f580a1e6f7e3d8d (patch)
tree6e24cc27f89c5b47e6e8e153793183b444e333a5
parentfef5fa48151071d4d287a2b772b81c88bec67cd5 (diff)
downloadguix-ffc6e0a391b76fc96b4311081f580a1e6f7e3d8d.tar.gz
gnu: sbcl-ptester: Remove Make reference from closure.
* gnu/packages/lisp-check.scm (sbcl-ptester)[source]: Delete the 'debian' folder.

This takes the closure size from 209 MiB down to 151 MiB.
-rw-r--r--gnu/packages/lisp-check.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 1795e050a4..b52f44e23f 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -695,7 +695,13 @@ advantages of @command{prove} are:
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "1l0lfl7cdnr2qf4zh38hi4llxg22c49zkm639bdkmvlkzwj3ndwf"))))
+          (base32 "1l0lfl7cdnr2qf4zh38hi4llxg22c49zkm639bdkmvlkzwj3ndwf"))
+         (modules '((guix build utils)))
+         (snippet
+          ;; The useless bundled debian folder drags `make' into the closure.
+          `(begin
+             (delete-file-recursively "debian")
+             #t))))
       (build-system asdf-build-system/sbcl)
       (home-page "http://quickdocs.org/ptester/")
       (synopsis "Portable test harness package")