summary refs log tree commit diff
diff options
context:
space:
mode:
authorVicente Vera Parra <vicentemvp@gmail.com>2015-09-15 14:24:46 -0300
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-21 10:48:26 +0200
commitffd4b478510b770966f5e5478d818be97a4ae06d (patch)
treeec72ef4a4bd7970c978318aea43481d92ee92366
parent5b9789a6ff16e0cbe951bed3a3f3dbd96fe706ec (diff)
downloadguix-ffd4b478510b770966f5e5478d818be97a4ae06d.tar.gz
gnu: Add r-r6.
* gnu/packages/statistics.scm (r-r6): New variable.
-rw-r--r--gnu/packages/statistics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 53d3e28d27..9e23cc720f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -833,3 +833,32 @@ New styles can also be created easily.  This package was inspired by the
      "This package provides a unit testing system for R designed to be fun,
 flexible and easy to set up.")
     (license license:expat)))
+
+(define-public r-r6
+  (package
+    (name "r-r6")
+    (version "2.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "R6" version))
+              (sha256
+               (base32
+                "16qq35bgxgswf989yvsqkb6fv7srpf8n8dv2s2c0z9n6zgmwq66m"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-knitr" ,r-knitr)
+       ("r-microbenchmark" ,r-microbenchmark)
+       ("r-pryr" ,r-pryr)
+       ("r-testthat" ,r-testthat)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-scales" ,r-scales)))
+    (home-page "https://github.com/wch/R6/")
+    (synopsis "Classes with reference semantics in R")
+    (description
+     "The R6 package allows the creation of classes with reference semantics,
+similar to R's built-in reference classes.  Compared to reference classes, R6
+classes are simpler and lighter-weight, and they are not built on S4 classes
+so they do not require the methods package.  These classes allow public and
+private members, and they support inheritance, even when the classes are
+defined in different packages.")
+    (license license:expat)))