summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-20 16:56:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:12:26 +0300
commit130c13c877db9252a9c578a66f65483a32fecd64 (patch)
treefa3d44414c0ba4e62990550008a4979b171a6f62
parent9e30f6590c5fa961689166d8eeeefba222c82b0c (diff)
downloadguix-130c13c877db9252a9c578a66f65483a32fecd64.tar.gz
gnu: Add julia-aqua.
* gnu/packages/julia-xyz.scm (julia-aqua): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 4d2b68e1c6..aea117395c 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -101,6 +101,26 @@ acts like @code{convert(T, x)}, but without the restriction of returning a
 be GPU compatible without throwing away the wrapper.")
     (license license:expat)))
 
+(define-public julia-aqua
+  (package
+    (name "julia-aqua")
+    (version "0.5.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaTesting/Aqua.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0zcvrwnyhh2kr4d2xv7ps8dh7byw78dx6yb1m9m4dblgscn5kypb"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/JuliaTesting/Aqua.jl")
+    (synopsis "Automated quality assurance for Julia packages")
+    (description "@acronym{Aqua.jl, Auto QUality Assurance for Julia packages},
+provides functions to run a few automatable checks for Julia packages.")
+    (license license:expat)))
+
 (define-public julia-benchmarktools
   (package
     (name "julia-benchmarktools")