summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-27 19:29:49 +0200
committerMarius Bakke <marius@gnu.org>2022-06-27 19:29:49 +0200
commit1e39cc64811e12d41b08ad301629c5669f42137a (patch)
treefbc50c59021adeed71ac54580f6cbeee194851f2
parent2a7648774f1bba5bb443c00b8ab1a2ab75b7416f (diff)
downloadguix-1e39cc64811e12d41b08ad301629c5669f42137a.tar.gz
gnu: OpenSSL: Absorb graft.
* gnu/packages/tls.scm (openssl): Update to 1.1.1p.
[replacement]: Remove.
(openssl/fixed): Remove variable.
-rw-r--r--gnu/packages/tls.scm24
1 files changed, 2 insertions, 22 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 7b2f43d993..0772eaeb76 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -350,8 +350,7 @@ OpenSSL for TARGET."
 (define-public openssl
   (package
     (name "openssl")
-    (version "1.1.1n")
-    (replacement openssl/fixed)
+    (version "1.1.1p")
     (source (origin
               (method url-fetch)
               (uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -364,7 +363,7 @@ OpenSSL for TARGET."
               (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
               (sha256
                (base32
-                "0ymif8rlc5cf5qp5bh2pxlrgq6xryh7g4sqfvrdjg9gnli8ypp20"))))
+                "0vyfibydji26wk1fmm0piz0810mfr7j4vaa2k5iwgiv6m8mbcqdz"))))
     (build-system gnu-build-system)
     (outputs '("out"
                "doc"        ;6.8 MiB of man3 pages and full HTML documentation
@@ -474,25 +473,6 @@ OpenSSL for TARGET."
     (license license:openssl)
     (home-page "https://www.openssl.org/")))
 
-(define openssl/fixed
-  (package
-    (inherit openssl)
-    (name "openssl")
-    (version "1.1.1p")
-    (source (origin
-              (method url-fetch)
-              (uri (list (string-append "https://www.openssl.org/source/openssl-"
-                                        version ".tar.gz")
-                         (string-append "ftp://ftp.openssl.org/source/"
-                                        "openssl-" version ".tar.gz")
-                         (string-append "ftp://ftp.openssl.org/source/old/"
-                                        (string-trim-right version char-set:letter)
-                                        "/openssl-" version ".tar.gz")))
-              (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
-              (sha256
-               (base32
-                "0vyfibydji26wk1fmm0piz0810mfr7j4vaa2k5iwgiv6m8mbcqdz"))))))
-
 (define-public openssl-3.0
   (package
     (inherit openssl)