summary refs log tree commit diff
diff options
context:
space:
mode:
authorHugo Buddelmeijer <hugo@buddelmeijer.nl>2023-03-06 21:23:13 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-21 19:13:34 +0100
commit2120c768f2366c92d72d15e4044a81c31e57688b (patch)
treec7b86bc44a0b90e6f49c499752a2254388b8209c
parent6a23ef814ade3cae0320127bd06732534247a76f (diff)
downloadguix-2120c768f2366c92d72d15e4044a81c31e57688b.tar.gz
gnu: python-pypandoc: Upgrade to 1.7.5.
The tests of python-pypandoc 1.6.5 fail; these are fixed in 1.7.5:
https://github.com/JessicaTegner/pypandoc/commit/6670e906dccaddcfcdec228e34e0eaffc20ae791

The tests of later versions of python-pypandoc also fail though:
https://github.com/JessicaTegner/pypandoc/pull/327

Finally, python-pypandoc requires the pandoc data to be embeded in
the binary:
https://github.com/jgm/pandoc/blob/main/INSTALL.md#creating-a-relocatable-binary

* gnu/packages/python-xyz.scm (python-pypandoc): Upgrade to 1.7.5
* gnu/packages/haskel-xyz.scm (pandoc): Embed data files.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell-xyz.scm3
-rw-r--r--gnu/packages/python-xyz.scm6
2 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 86af842980..f2cc60267b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8315,6 +8315,9 @@ provided for those who need a drop-in replacement for Markdown.pl.")
     (name "pandoc")
     (arguments
      (list
+       ;; Create entirely self-contained binary by embedding the data files
+       ;; in the binary itself. Required for python-pypandoc.
+       #:configure-flags #~(list "-fembed_data_files")
        #:phases
        #~(modify-phases %standard-phases
            (add-after 'register 'remove-libraries
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ac10290237..9d086136d0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27787,17 +27787,17 @@ By default it uses the open Python vulnerability database Safety DB.")
 (define-public python-pypandoc
   (package
     (name "python-pypandoc")
-    (version "1.6.4")
+    (version "1.7.5")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pypandoc" version))
        (sha256
         (base32
-         "149basv4pvzg9zm74cjz68x8s2n5fykyj7prgysb0qfmja73r83f"))))
+         "0l6a8ngzpx363q2jskxxkx6psfhqrvc4js80dmn16r3vw6m2cb40"))))
     (build-system python-build-system)
     (inputs
-     (list pandoc))
+     (list pandoc python-pandocfilters))
     (propagated-inputs
      `(("wheel" ,python-wheel)))
     (native-inputs