summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 17:52:33 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 00:12:51 +0200
commit2c3c8ac45dd16892fe9bd701c1c7a3766774e573 (patch)
treebb670bcdf769f906b179f2f80c2dab74f05b2113
parentc1700a9bae403b76fad1648123269e906f94cab6 (diff)
downloadguix-2c3c8ac45dd16892fe9bd701c1c7a3766774e573.tar.gz
gnu: Add texlive-latex-pdftexcmds.
* gnu/packages/tex.scm (texlive-latex-pdftexcmds): New public variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a6a0369111..bb81b836ee 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4257,6 +4257,26 @@ that are compatible with @code{natbib}: @code{plainnat}, @code{unsrtnat},
 designed from the start to be compatible with @code{natbib}.")
     (license license:lppl)))
 
+(define-public texlive-latex-pdftexcmds
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-pdftexcmds"
+              '("/doc/latex/pdftexcmds/"
+                "/tex/latex/pdftexcmds/")
+              (base32
+               "0kqav8jri789698wxwr2ww8ssn74fvw3agrv677nz5qyq5zmix8h")
+              #:trivial? #t))
+    (propagated-inputs
+     `(("texlive-generic-iftex" ,texlive-generic-iftex)
+       ("texlive-generic-infwarerr" ,texlive-generic-infwarerr)
+       ("texlive-generic-ltxcmds" ,texlive-generic-ltxcmds)))
+    (home-page "https://www.ctan.org/pkg/pdftexcmds")
+    (synopsis "LuaTeX support for pdfTeX utility functions")
+    (description
+     "This package makes a number of utility functions from pdfTeX
+available for luaTeX by reimplementing them using Lua.")
+    (license license:lppl1.3c+)))
+
 (define-public texlive-latex-psfrag
   (package
     (name "texlive-latex-psfrag")