summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:15:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:53 +0300
commit2ee28bfc9f43df97913c5e54fe1206b92ef6662b (patch)
tree4ab97dfc8c42d2f3fef937ad69d26cc1041d9120
parentcf4a0c1f67003146057597363f06bb0056687e0f (diff)
downloadguix-2ee28bfc9f43df97913c5e54fe1206b92ef6662b.tar.gz
gnu: Add julia-libgcrypt-jll.
* gnu/packages/julia-jll.scm (julia-libgcrypt-jll): New variable.
-rw-r--r--gnu/packages/julia-jll.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 87cd840b9e..73214cb652 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -696,6 +696,45 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
     (description "This package provides a wrapper for the libffi library.")
     (license license:expat)))
 
+(define-public julia-libgcrypt-jll
+  (package
+    (name "julia-libgcrypt-jll")
+    (version "1.8.7+0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaBinaryWrappers/Libgcrypt_jll.jl")
+               (commit (string-append "Libgcrypt-v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "06fsdwrfw3f4cdbg1ssswznvj8ar3w5w4vxxag1hacs14pxlm5gi"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+               (lambda (wrapper)
+                 (substitute* wrapper
+                  (("generate_wrapper_header.*")
+                   (string-append
+                     "generate_wrapper_header(\"Libgcrypt\", \""
+                     (assoc-ref inputs "libgcrypt") "\")\n"))))
+               ;; There's a Julia file for each platform, override them all
+               (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     `(("libgcrypt" ,libgcrypt)))
+    (propagated-inputs
+     `(("julia-jllwrappers" ,julia-jllwrappers)
+       ("julia-libgpg-error-jll" ,julia-libgpg-error-jll)))
+    (home-page "https://github.com/JuliaBinaryWrappers/Libgcrypt_jll.jl")
+    (synopsis "libgcrypt library wrappers")
+    (description "This package provides a wrapper for the libgcrypt library.")
+    (license license:expat)))
+
 (define-public julia-libgpg-error-jll
   (package
     (name "julia-libgpg-error-jll")