summary refs log tree commit diff
diff options
context:
space:
mode:
authorCharles <charles.b.jackson@protonmail.com>2021-11-26 02:16:39 -0600
committerGuillaume Le Vaillant <glv@posteo.net>2021-11-26 13:41:22 +0100
commit38745deaec4a1a33c0e4de3c7caf1f1ae6894bd8 (patch)
tree11456bbceb2f34978807bdbf19ffa37a42f01e8e
parentb90504cdb5ce3d1981c8d7bc8a9cc918b0d60af7 (diff)
downloadguix-38745deaec4a1a33c0e4de3c7caf1f1ae6894bd8.tar.gz
gnu: Update cl-salza2 to 2.1.
* gnu/packages/lisp-xyz.scm (sbcl-salza2): Update to 2.1.
  [inputs]: Add trivial-gray-streams.
  [native-inputs]: Add chipz, flexi-streams and parachute.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 9748293f94..b8e9a0eae5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9089,7 +9089,7 @@ ones.")
 (define-public sbcl-salza2
   (package
     (name "sbcl-salza2")
-    (version "2.0.9")
+    (version "2.1")
     (source
      (origin
        (method git-fetch)
@@ -9098,8 +9098,14 @@ ones.")
              (commit (string-append "release-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0p38rj4gq7j5k807php7hrz7l2zyyfshv8i9yms7i8lkgg3433ki"))))
+        (base32 "1p48lxdibnps5rpyh5cmnk0vc77bmmxb32qdzfz93zadr8wwas10"))))
     (build-system asdf-build-system/sbcl)
+    (native-inputs
+     `(("chipz" ,sbcl-chipz)
+       ("flexi-streams" ,sbcl-flexi-streams)
+       ("parachute" ,sbcl-parachute)))
+    (inputs
+     `(("trivial-gray-streams" ,sbcl-trivial-gray-streams)))
     (synopsis "Common Lisp library for zlib, deflate and gzip compression")
     (description
      "Salza2 is a Common Lisp library for creating compressed data in the zlib,