summary refs log tree commit diff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2022-11-14 13:44:22 +0800
committerLudovic Courtès <ludo@gnu.org>2022-11-28 23:34:15 +0100
commit42eccda8277d43446a3381835f8c0a95ae643973 (patch)
treeb68eaa72e6ade3d2cf18d1a5d8113236bab4b442
parent3c8e3d0f90bc3ac85ea22cbd7be3322985589084 (diff)
downloadguix-42eccda8277d43446a3381835f8c0a95ae643973.tar.gz
gnu: Add python-pynixutil.
* gnu/packages/python-xyz.scm (python-pynixutil): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 87963f9f19..e87c6bc0b4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23082,6 +23082,32 @@ environments.")
      "PyNamecheap is a Namecheap API client in Python.")
     (license license:expat)))
 
+(define-public python-pynixutil
+  (package
+    (name "python-pynixutil")
+    (version "0.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nix-community/pynixutil")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              ;; Derivation test uses nix.
+              (modules '((guix build utils)))
+              (snippet '(delete-file "tests/test_drv.py"))
+              (sha256
+               (base32
+                "1lnspcai7mqpv73bbd8kgyw63fxwgkwvfkl09b2bl5y2g2v7np6m"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list poetry python-pytest))
+    (home-page "https://github.com/nix-community/pynixutil")
+    (synopsis "Utility functions for working with data from Nix in Python")
+    (description
+     "@code{pynixutil} provides functions for base32 encoding/decoding and
+derivation parsing, namingly @code{b32decode()}, @code{b32encode()} and
+@code{drvparse()}.")
+    (license license:expat)))
+
 (define-public python-dns-lexicon
   (package
     (name "python-dns-lexicon")