summary refs log tree commit diff
diff options
context:
space:
mode:
authorSigve Sudland <sigve_sudland@hotmail.com>2023-07-19 23:02:34 +0200
committerJohn Kehayias <john.kehayias@protonmail.com>2023-07-25 16:22:12 -0400
commit43d07068bb9ed46874b934a7eb8c891151a69c49 (patch)
tree80a20526f65b90ff4dbbec10f5f6b58794d0a809
parent5555f3f98e97f8bbcd6ce9bc6b76a6eb20566f55 (diff)
downloadguix-43d07068bb9ed46874b934a7eb8c891151a69c49.tar.gz
gnu: mesa: Enable zstd compression for shader cache.
* gnu/packages/gl.scm (mesa)[inputs]: Add zstd:lib.
[arguments]: Add '-Dzstd=enabled' to configure-flags.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/gl.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 9325d41907..86be6e0bb1 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -298,7 +298,8 @@ also known as DXTn or DXTC) for Mesa.")
            libxvmc
            llvm-for-mesa
            wayland
-           wayland-protocols))
+           wayland-protocols
+           `(,zstd "lib")))
     (native-inputs
      (list bison
            flex
@@ -362,6 +363,9 @@ svga,swrast,virgl")))
          ;; 21.3.x releases to avoid functionality regressions.
          "-Dvideo-codecs=vc1dec,h264dec,h264enc,h265dec,h265enc"
 
+         ;; Enable ZSTD compression for shader cache.
+         "-Dzstd=enabled"
+
          ;; Also enable the tests.
          "-Dbuild-tests=true"