summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaciej Kalandyk <m.kalandyk@outlook.com>2023-05-25 20:29:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-25 22:19:37 +0200
commit45c173b3c8cf26fd44d6c67c88042d3872647fd6 (patch)
tree48e9332cb7d467f5e8f397b45713f01e7246628f
parent0f8b84b3904300ad14d440859fd9b01d23889cc4 (diff)
downloadguix-45c173b3c8cf26fd44d6c67c88042d3872647fd6.tar.gz
gnu: Add emacs-prism.
* gnu/packages/emacs-xyz.scm (emacs-prism): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e57992daca..f3700ddd7e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1191,6 +1191,28 @@ and inserts a SpongeBob SquarePants ASCII art figure in the current
 buffer.")
       (license license:gpl3+))))
 
+(define-public emacs-prism
+  (package
+    (name "emacs-prism")
+    (version "0.3.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/alphapapa/prism.el")
+                    (commit version)))
+              (sha256
+               (base32
+                "0n2gf7302hqdnhsax1y3ahksfmmpd8cmiv1zgb7rjg8qhcs0iqp2"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-dash))
+    (home-page "https://github.com/alphapapa/prism.el")
+    (synopsis
+     "Disperses bracket-bounded syntax into a spectrum of color by depth")
+    (description
+     "Prism is a Rainbow Blocks-like mode for Emacs.  It preserves non-color
+face properties and allows configuration of faces and colors.")
+    (license license:gpl3+)))
+
 (define-public emacs-project
   (package
     (name "emacs-project")