summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-03 20:51:33 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-12-30 21:32:39 +0100
commit4c5f7dac9df95fb17a12ea15d29eff86ed36eb0a (patch)
tree7d4402cbc7d4c72494c2116d89d096fa19ccb861
parent0ccb46a926e14bc70ecaf27a19f22e4726cd2de4 (diff)
downloadguix-4c5f7dac9df95fb17a12ea15d29eff86ed36eb0a.tar.gz
gnu: rust-version-compare 0.0.11: Fix variable name.
In semanic versioning, the last non-zero numer is relevant. 0.0.10 is not
expected to be compatible with 0.0.11.

* gnu/packages/crates-io.scm: (rust-version-compare-0.0.11): Rename from …
  (rust-version-compare-0.0): … this, which becomes an alias of the former.
  (rust-system-deps-1)[source]<snippet>: Use new version string.
  [arguments]<#:cargo-inputs>: Use new variable name.
-rw-r--r--gnu/packages/crates-io.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ee0486cd8b..65e8fbae09 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -54473,7 +54473,7 @@ dependencies declarative, so other tools can read them as well.")
        (modules '((guix build utils)))
        (snippet
         '(begin (substitute* "Cargo.toml"
-                  (("0.0.10") "0.0"))
+                  (("0.0.10") "0.0.11"))
                 #t))))
     (arguments
      `(#:tests? #f                      ;source is missing some test files
@@ -54484,7 +54484,7 @@ dependencies declarative, so other tools can read them as well.")
         ("rust-strum-macros" ,rust-strum-macros-0.18)
         ("rust-thiserror" ,rust-thiserror-1)
         ("rust-toml" ,rust-toml-0.5)
-        ("rust-version-compare" ,rust-version-compare-0.0))
+        ("rust-version-compare" ,rust-version-compare-0.0.11))
        #:cargo-development-inputs
        (("rust-itertools" ,rust-itertools-0.9))))))
 
@@ -62186,7 +62186,7 @@ If that fails, no determination is made, and calls return None.")
          (base32
           "1pf91pvj8n6akh7w6j5ypka6aqz08b3qpzgs0ak2kjf4frkiljwi"))))))
 
-(define-public rust-version-compare-0.0
+(define-public rust-version-compare-0.0.11
   (package
     (name "rust-version-compare")
     (version "0.0.11")
@@ -62206,6 +62206,8 @@ If that fails, no determination is made, and calls return None.")
 numbers, and test them against various comparison operators.")
     (license license:expat)))
 
+(define-public rust-version-compare-0.0 rust-version-compare-0.0.11)
+
 (define-public rust-version-sync-0.8
   (package
     (name "rust-version-sync")