summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-07-25 16:18:30 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-07-25 16:18:30 -0400
commit5555f3f98e97f8bbcd6ce9bc6b76a6eb20566f55 (patch)
tree17b6b1c2513581cd9842b5fdf7599a5cc90f871c
parentf4d7610a9b86745277782b0677507486f8e88d66 (diff)
downloadguix-5555f3f98e97f8bbcd6ce9bc6b76a6eb20566f55.tar.gz
gnu: mesa: Ungraft.
* gnu/packages/gl.scm (mesa)[configure-flags]: Add intel_hasvk and swrast to
vulkan-drivers.
[replacement]: Remove.
(mesa-vulkan-hasvk): Remove variable.
-rw-r--r--gnu/packages/gl.scm18
1 files changed, 1 insertions, 17 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index d42903cc8f..9325d41907 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -279,7 +279,6 @@ also known as DXTn or DXTC) for Mesa.")
          (base32
           "1mcjf41x2bhxs6yxars7nh2vfryfw50g6rvbcfbb1wqdv2jn4qrq"))))
     (build-system meson-build-system)
-    (replacement mesa-vulkan-hasvk)
     (propagated-inputs
      ;; The following are in the Requires.private field of gl.pc.
      (list libdrm
@@ -346,7 +345,7 @@ svga,swrast,virgl")))
          ;; Explicitly enable Vulkan on some architectures.
          #$@(match (%current-system)
              ((or "i686-linux" "x86_64-linux")
-              '("-Dvulkan-drivers=intel,amd"))
+              '("-Dvulkan-drivers=intel,intel_hasvk,amd,swrast"))
              ((or "powerpc64le-linux" "powerpc-linux")
               '("-Dvulkan-drivers=amd,swrast"))
              ("aarch64-linux"
@@ -528,21 +527,6 @@ device drivers allows Mesa to be used in many different environments ranging
 from software emulation to complete hardware acceleration for modern GPUs.")
     (license license:x11)))
 
-(define mesa-vulkan-hasvk
-  (let ((graft mesa)
-        (vulk "-Dvulkan-drivers=intel,amd"))
-    (package
-      (inherit graft)
-      (arguments
-        (substitute-keyword-arguments (package-arguments graft)
-          ((#:configure-flags flags)
-           #~(begin
-               (use-modules (ice-9 match))
-               (map (match-lambda
-                      (#$vulk (string-append #$vulk ",intel_hasvk,swrast"))
-                      (x x))
-                 #$flags))))))))
-
 (define-public mesa-opencl
   (package/inherit mesa
     (name "mesa-opencl")