summary refs log tree commit diff
diff options
context:
space:
mode:
authorAhmad Draidi <a.r.draidi@redscript.org>2023-07-16 11:16:38 +0400
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-23 09:50:07 +0200
commit79af3f83665f6e0416259177ed4a1f27860a5c81 (patch)
treec7fb2b17528ef26652c54e2bb0c2ac7a76460af1
parentf88a7d82c7daf84d074a14acbc9fad75b21dbe58 (diff)
downloadguix-79af3f83665f6e0416259177ed4a1f27860a5c81.tar.gz
gnu: Add emacs-consult-flycheck.
* gnu/packages/emacs-xyz.scm (emacs-consult-flycheck): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3f2e168d32..2835e7d8f1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11402,6 +11402,31 @@ provides a front-end interface for the workspace/symbols LSP procedure
 call.")
    (license license:gpl3+)))
 
+(define-public emacs-consult-flycheck
+  ;; This particular commit introduces bug fixes above latest release.
+  (let ((commit "3f2a7c17cc2fe64e0c07e3bf90e33c885c0d7062")
+        (revision "0"))
+    (package
+      (name "emacs-consult-flycheck")
+      (version (git-version "0.9" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/minad/consult-flycheck")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0cvxl6ynbns3wlpzilhg4ldakb91ikpibbr9wpb2wkzbgi5c766c"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list emacs-consult emacs-flycheck))
+      (home-page "https://github.com/minad/consult-flycheck")
+      (synopsis "Consult integration for Flycheck")
+      (description
+       "This package provides the @code{consult-flycheck} command for Emacs,
+ which integrates @code{Consult} with @code{Flycheck}.")
+      (license license:gpl3+))))
+
 (define-public emacs-eglot-tempel
   (let ((commit "e08b203d6a7c495d4b91ed4537506b5f1ea8a84f")
         (revision "0"))