summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2023-03-21 18:12:25 -0500
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-22 14:14:38 +0100
commit7f1f78c9463680d5e364815e7d6db0031e6cb566 (patch)
treefc299c7b64f30bdc039b17a36e39e5b8c1fd6c3d
parent7f41603da02acd0a30f94f39b3a51a361fc4ec76 (diff)
downloadguix-7f1f78c9463680d5e364815e7d6db0031e6cb566.tar.gz
gnu: sbcl-trivial-open-browser: Fix path to xdg-open.
* gnu/packages/lisp-xyz.scm (sbcl-trivial-open-browser)[inputs]: Add
  xdg-utils.
  [arguments]: Add 'fix-paths' phase.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5be5df1d7f..d4b0a70270 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -80,6 +80,7 @@
   #:use-module (gnu packages file)
   #:use-module (gnu packages fonts)
   #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages game-development)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
@@ -22648,10 +22649,20 @@ higher-level lispier interface.")
          (uri (git-reference
                (url "https://github.com/eudoxia0/trivial-open-browser")
                (commit commit)))
-         (file-name (git-file-name "trivial-open-browser" version))
+         (file-name (git-file-name "cl-trivial-open-browser" version))
          (sha256
           (base32 "0ixay1piq420i6adx642qhw45l6ik7rvgk52lyz27dvx5f8yqsdb"))))
       (build-system asdf-build-system/sbcl)
+      (inputs (list xdg-utils))
+      (arguments
+       (list
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'fix-paths
+              (lambda* (#:key inputs #:allow-other-keys)
+                (substitute* "src/trivial-open-browser.lisp"
+                  (("xdg-open")
+                   (search-input-file inputs "/bin/xdg-open"))))))))
       (home-page "https://github.com/eudoxia0/trivial-open-browser")
       (synopsis "Open a browser window from Common Lisp")
       (description