summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 17:53:19 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 00:12:51 +0200
commit935784ba3457b0e66f493e724c1e76eb5a4ac531 (patch)
tree3f5a2b6e3284cc927b465624f48810ddb4149127
parent2c3c8ac45dd16892fe9bd701c1c7a3766774e573 (diff)
downloadguix-935784ba3457b0e66f493e724c1e76eb5a4ac531.tar.gz
gnu: Add texlive-latex-letltxmacro.
* gnu/packages/tex.scm (texlive-latex-letltxmacro): New public variable.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bb81b836ee..08ef375696 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5064,6 +5064,24 @@ the same place.  The package also has a range of techniques for labelling
 footnotes with symbols rather than numbers.")
     (license license:lppl1.3+)))
 
+(define-public texlive-latex-letltxmacro
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-letltxmacro"
+              (list "/doc/latex/letltxmacro/"
+                    "/tex/latex/letltxmacro/")
+              (base32
+               "0yy1m1jiyxq2pssp0pidaa2swx6lyxw3zwpm2r8m0v2r3lvsyyxx")
+              #:trivial? #t))
+    (home-page "https://www.ctan.org/pkg/letltxmacro")
+    (synopsis "Let assignment for macros")
+    (description
+     "TeX’s @code{\\let} assignment does not work for LaTeX macros with
+optional arguments, or for macros that are defined as robust macros by
+@code{\\DeclareRobustCommand}.  This package defines @code{\\LetLtxMacro}
+that also takes care of the involved internal macros.")
+    (license license:lppl1.3c+)))
+
 (define-public texlive-latex-listings
   (package
     (name "texlive-latex-listings")