summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-09 23:11:21 +0200
committerMarius Bakke <marius@gnu.org>2021-05-09 23:12:48 +0200
commit9430debf2937c4c5f331720387e72a75df3fb662 (patch)
tree2f781715a9e5b79728d614aa404a761ad84b6876
parenta9517c4f59f9819c1ffdcc4cefe472f7e1760fc2 (diff)
downloadguix-9430debf2937c4c5f331720387e72a75df3fb662.tar.gz
gnu: python-urllib3: Remove replacement package.
* gnu/packages/python-web.scm (python-urllib3): Update to 1.26.4.
[replacement]: Remove.
(python-urllib3/fixed): Remove variable.
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 27c08d263b..8b31368424 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2736,15 +2736,14 @@ authenticated session objects providing things like keep-alive.")
 (define-public python-urllib3
   (package
     (name "python-urllib3")
-    (version "1.26.2")
+    (version "1.26.4")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "urllib3" version))
         (sha256
          (base32
-          "024yldjwjavps39yb77sc422z8fa9bn20wcqrcncjwrqjab8y60r"))))
-    (replacement python-urllib3/fixed)
+          "0dw9w9bs3hmr5dp3r3h43jyzzb1g1046ag7lj8pqf58i4kvj3c77"))))
     (build-system python-build-system)
     (arguments `(#:tests? #f))
     (propagated-inputs
@@ -2763,17 +2762,6 @@ supports url redirection and retries, and also gzip and deflate decoding.")
     (properties `((python2-variant . ,(delay python2-urllib3))))
     (license license:expat)))
 
-(define python-urllib3/fixed
-  (package/inherit python-urllib3
-    (version "1.26.4")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "urllib3" version))
-       (sha256
-        (base32
-         "0dw9w9bs3hmr5dp3r3h43jyzzb1g1046ag7lj8pqf58i4kvj3c77"))))))
-
 ;; Some software requires an older version of urllib3, notably Docker.
 (define-public python-urllib3-1.24
   (package (inherit python-urllib3)