summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-08 14:00:27 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-05 13:20:15 +0200
commit9b07ebcd9634cb96bef061fd8089ff0ef4d108f9 (patch)
tree82efb8b5f1950d1405d6980ee06a8ed5faa4c639
parent1c2126c377bb5367b1f3ace599f214fabc0d5925 (diff)
downloadguix-9b07ebcd9634cb96bef061fd8089ff0ef4d108f9.tar.gz
gnu: Add rust-colored-1.9.1.
This is sequried by sequoia, resp. sequois-sqv.

* gnu/packages/crates-io.scm (rust-colored-1.9.1): New variable.
-rw-r--r--gnu/packages/crates-io.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2c7a17a39e..7bc3d7a8f3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3353,6 +3353,19 @@ CMAKE environmental variable is set.")
      "The most simple way to add colors in your terminal.")
     (license license:mpl2.0)))
 
+(define-public rust-colored-1.9.1
+  (package/inherit rust-colored-1.9
+    (name "rust-colored")
+    (version "1.9.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "colored" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0fildacm47g86acmx44yvxx6cka8fdym5qkgfm8x8gh2hsrghc7r"))))
+    (build-system cargo-build-system)))
+
 ;; This package requires features which are unavailable
 ;; on the stable releases of Rust.
 (define-public rust-compiler-builtins-0.1