summary refs log tree commit diff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2022-10-02 00:56:44 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-10-06 16:58:15 +0300
commitb86867417fa76384eae76fcef099cf4d133bb20d (patch)
tree297ec30aa1a828927cb72f2515cd004f93e9e5cf
parent2408a10325e7ad2c28ba84b5c8d5bf1c2979863c (diff)
downloadguix-b86867417fa76384eae76fcef099cf4d133bb20d.tar.gz
gnu: celluloid: Do not install icon cache.
Fixes <https://issues.guix.gnu.org/58207>.

* gnu/packages/video.scm (celluloid)[arguments]: Add phase
disable-postinstall-script so postinstall-script does nothing. Build
with glib-or-gtk meson option.
[native-inputs]: Remove desktop-file-utils, gtk:bin.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/video.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 5568c5be8b..e6da6ce04f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -785,12 +785,18 @@ old-fashioned output methods with powerful ascii-art renderer.")
        (sha256
         (base32 "0ns9xh582c8kajw4v2x5ap5jfiba3gxywqc2klc0v6fc3id1gqii"))))
     (build-system meson-build-system)
+    (arguments
+     (list
+      #:glib-or-gtk? #t
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'disable-postinstall-script
+            (lambda _
+              (setenv "DESTDIR" "/"))))))
     (native-inputs
      (list
-      desktop-file-utils           ; for update-desktop-database
       intltool
       `(,glib "bin")               ; for glib-compile-resources
-      `(,gtk "bin")                ; for gtk-update-icon-cache
       pkg-config
       python-wrapper))             ; for generate-authors.py
     (inputs