summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 22:53:43 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:40 -0500
commitc022a4d4e43cbed72517f145b8f72c41d8db401c (patch)
tree2bdebc385c702fab8a1d7cf49c343a4fd5c66eec
parent5ffe8cfdc3c20e589ebbffac00c18878a884814c (diff)
downloadguix-c022a4d4e43cbed72517f145b8f72c41d8db401c.tar.gz
gnu: Add ghc-time-manager.
* gnu/packages/haskell-xyz.scm (ghc-time-manager): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 83e56741ee..0da0212e50 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10780,6 +10780,27 @@ features as possible.")
 @code{TimeLocale}.")
     (license license:bsd-3)))
 
+(define-public ghc-time-manager
+  (package
+    (name "ghc-time-manager")
+    (version "0.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "time-manager/time-manager-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1nzwj0fxz370ks6vr1sylcidx33rnqq45y3q9yv9n4dj43nid9lh"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-auto-update" ,ghc-auto-update)))
+    (home-page "https://github.com/yesodweb/wai")
+    (synopsis "Scalable timer")
+    (description "This library contains scalable timer functions provided by a
+timer manager.")
+    (license license:expat)))
+
 (define-public ghc-timeit
   (package
     (name "ghc-timeit")