summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 17:56:55 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 00:12:51 +0200
commitc1700a9bae403b76fad1648123269e906f94cab6 (patch)
treede51b3ebfabecf84c8e3d2977689b514a5da497b
parentd136754211a9567afe5a3e5a7ef6271f925bdf26 (diff)
downloadguix-c1700a9bae403b76fad1648123269e906f94cab6.tar.gz
gnu: Add texlive-generic-ltxcmds.
* gnu/packages/tex.scm (texlive-generic-ltxcmds): New public variable.
-rw-r--r--gnu/packages/tex.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0f4527bcc2..a6a0369111 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7295,6 +7295,22 @@ the parsing character has been selected by the user, and to access any of
 these items with a simple syntax.")
     (license license:lppl1.3c+)))
 
+(define-public texlive-generic-ltxcmds
+  (package
+    (inherit (simple-texlive-package
+              "texlive-generic-ltxcmds"
+              '("/tex/generic/ltxcmds/")
+              (base32
+               "0mdzy76sbc3pmas5zqxn35w9xcg4v7j4p31jcjm9f4hzm27y974a")
+              #:trivial? #t))
+    (home-page "https://www.ctan.org/pkg/ltxcmds")
+    (synopsis "LaTeX kernel commands extracted for general use")
+    (description
+     "This package exports some utility macros from the LaTeX kernel into
+a separate namespace and also makes them available for other formats such
+as plain TeX.")
+    (license license:lppl1.3c+)))
+
 (define-public texlive-latex-readarray
   (package
     (name "texlive-latex-readarray")