summary refs log tree commit diff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-12-04 01:29:27 -0600
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-12-10 09:13:32 +0100
commitd0a038b17a99e0ba25703e44177988d0a1ab1cc6 (patch)
tree9e73cf6ad3be6d8314a1e8902d774bb85998e139
parent3ae6f30767f962da74d18d824b521462e149b89a (diff)
downloadguix-d0a038b17a99e0ba25703e44177988d0a1ab1cc6.tar.gz
gnu: Add emacs-carp.
* gnu/packages/emacs-xyz.scm (emacs-carp): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0d11c59b48..aafa7240fd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2977,6 +2977,31 @@ defined in RFC 2425 and RFC 2426 to/from The Insidious Big Brother Database
 shine on top of your cursor so you know where it is.")
     (license license:gpl3+)))
 
+(define-public emacs-carp
+  (let ((commit "17d3d84963434233997626850195f205882bf0df")
+        (revision "0"))
+    (package
+      (name "emacs-carp")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (uri (git-reference
+               (url "https://github.com/carp-lang/carp-emacs")
+               (commit commit)))
+         (method git-fetch)
+         (sha256
+          (base32 "0mn4mg94hzzwb54kikg4c6hvf9ka15f2nz95g0clmn8r0mvkj4d5"))
+         (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+        (list emacs-clojure-mode emacs-flycheck))
+      (home-page "https://github.com/carp-lang/carp-emacs")
+      (synopsis "Emacs support for Carp")
+      (description
+       "This package provides syntax highlighting, a minor mode for
+listing type errors via Flycheck, as well as REPL support for Carp.")
+      (license license:asl2.0))))
+
 (define-public emacs-counsel-bbdb
   (package
     (name "emacs-counsel-bbdb")