summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-05 01:21:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-05 01:36:23 +0200
commitd20ce8875807971b623144c7d1525f51eab12316 (patch)
tree0d3666c3403da46e211117e3cfec0788ae91e7c9
parent705007945f4ae6f4065ba26a68ca15c2a357b1af (diff)
downloadguix-d20ce8875807971b623144c7d1525f51eab12316.tar.gz
gnu: bridge-utils: Remove obsolete phases.
* gnu/packages/linux.scm (bridge-utils)[arguments]: Remove all custom phases.
-rw-r--r--gnu/packages/linux.scm18
1 files changed, 1 insertions, 17 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 58ec55ebd3..44d578c71b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2930,23 +2930,7 @@ Linux-based operating systems.")
     (native-inputs `(("autoconf" ,autoconf)
                      ("automake" ,automake)))
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-before 'bootstrap 'patch-stuff
-           (lambda _
-             ;; Fix "field ‘ip6’ has incomplete type" errors.
-             (substitute* "libbridge/libbridge.h"
-               (("#include <linux/if_bridge.h>")
-                "#include <linux/in6.h>\n#include <linux/if_bridge.h>"))
-
-             ;; Ensure that the entire build fails if one of the
-             ;; sub-Makefiles fails.
-             (substitute* "Makefile.in"
-               (("\\$\\(MAKE\\) \\$\\(MFLAGS\\) -C \\$\\$x ;")
-                "$(MAKE) $(MFLAGS) -C $$x || exit 1;"))
-
-             #t)))
-       #:tests? #f))                              ; no 'check' target
+     '(#:tests? #f))                    ; no 'check' target
 
     (home-page "https://wiki.linuxfoundation.org/networking/bridge")
     (synopsis "Manipulate Ethernet bridges")