summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-02 12:00:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-02 13:39:10 +0200
commitd73c5728f345174e9493a25646cd3d1a716fb8b5 (patch)
tree129f5e06c25f0d7dafd92d09c318b62f1628da9f
parentc76e8baf9e57a45c19ccc0134499b493b55ea8a9 (diff)
downloadguix-d73c5728f345174e9493a25646cd3d1a716fb8b5.tar.gz
gnu: r-rhdf5: Update to 2.24.0.
* gnu/packages/bioinformatics.scm (r-rhdf5): Update to 2.24.0.
[arguments]: Remove.
[propagated-inputs]: Remove r-zlibbioc; add r-rhdf5lib.
[inputs]: Remove perl.
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 4 insertions, 25 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9138671d2f..ce4ff64af6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8797,39 +8797,18 @@ of gene-level counts.")
 (define-public r-rhdf5
   (package
     (name "r-rhdf5")
-    (version "2.22.0")
+    (version "2.24.0")
     (source (origin
               (method url-fetch)
               (uri (bioconductor-uri "rhdf5" version))
               (sha256
                (base32
-                "145858qg1xan6imxcbprzq3yn3mdf532aahdr6cibvdjg47hs4c1"))))
+                "15cmmchhk8bnp94gxg0zk9qyzdjx5kv16dzpbnb62mkq7ydmifx6"))))
     (build-system r-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'unpack-smallhdf5
-           (lambda* (#:key outputs #:allow-other-keys)
-             (system* "tar" "-xzvf"
-                      "src/hdf5source/hdf5small.tgz" "-C" "src/" )
-             (substitute* "src/hdf5/configure"
-               (("/bin/mv") "mv"))
-             ;; Remove timestamp and host system information to make
-             ;; the build reproducible.
-             (substitute* "src/hdf5/src/libhdf5.settings.in"
-               (("Configured on: @CONFIG_DATE@")
-                "Configured on: Guix")
-               (("Uname information:.*")
-                "Uname information: Linux\n")
-               ;; Remove unnecessary store reference.
-               (("C Compiler:.*")
-                "C Compiler: GCC\n"))
-             #t)))))
     (propagated-inputs
-     `(("r-zlibbioc" ,r-zlibbioc)))
+     `(("r-rhdf5lib" ,r-rhdf5lib)))
     (inputs
-     `(("perl" ,perl)
-       ("zlib" ,zlib)))
+     `(("zlib" ,zlib)))
     (home-page "https://bioconductor.org/packages/rhdf5")
     (synopsis "HDF5 interface to R")
     (description