summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 12:55:37 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:21 -0500
commitdcfb99d4cb88e210ecdf07e4a32914b0eef9949f (patch)
tree28e6608f008c5ff95164d9ea62d9ba70d3afed7a
parente0e21831d33b97a40cdac6fb44e873539bcbc316 (diff)
downloadguix-dcfb99d4cb88e210ecdf07e4a32914b0eef9949f.tar.gz
gnu: ghc-system-fileio: Update to 0.3.16.4.
* gnu/packages/haskell-xyz.scm (ghc-system-fileio): Update to 0.3.16.4.
[arguments]: Add a phase that updates the Cabal file to allow for newer
versions of 'chell'.
-rw-r--r--gnu/packages/haskell-xyz.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 360fbec509..946948be99 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10002,7 +10002,7 @@ variety of traversals.")
 (define-public ghc-system-fileio
   (package
     (name "ghc-system-fileio")
-    (version "0.3.16.3")
+    (version "0.3.16.4")
     (source
      (origin
        (method url-fetch)
@@ -10011,8 +10011,16 @@ variety of traversals.")
              version ".tar.gz"))
        (sha256
         (base32
-         "1484hcl27s2qcby8ws5djj11q9bz68bspcifz9h5gii2ndy70x9i"))))
+         "1iy6g1f35gzyj12g9mdiw4zf75mmxpv1l8cyaldgyscsl648pr9l"))))
     (build-system haskell-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'update-constraints
+           (lambda _
+             (substitute* "system-fileio.cabal"
+               (("chell >= 0\\.4 && < 0\\.5") "chell >= 0.4"))
+             #t)))))
     (inputs
      `(("ghc-system-filepath" ,ghc-system-filepath)
        ("ghc-chell" ,ghc-chell)