summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-12 17:00:33 +0100
committerMarius Bakke <marius@gnu.org>2022-12-12 20:23:31 +0100
commite1fc45b3eaaa2d09e3e202aff023b8aea6debbc9 (patch)
tree3ae5a328ccfe2c364d9bddf68402e9500a055a5b
parent61f67290b95adb537eebde13251d5c1c2dfc1687 (diff)
downloadguix-e1fc45b3eaaa2d09e3e202aff023b8aea6debbc9.tar.gz
gnu: f2fs-tools@1.7: Don't fetch autogenerated git snapshot.
* gnu/packages/linux.scm (f2fs-tools-1.7)[source]: Switch to GIT-FETCH.
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 485bc6d0f5..d483970dbb 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5976,13 +5976,15 @@ disks and SD cards.  This package provides the userland utilities.")
     (name "f2fs-tools")
     (version "1.7.0")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://git.kernel.org/cgit/linux/kernel/git/jaegeuk"
-                    "/f2fs-tools.git/snapshot/f2fs-tools-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url (git-reference-url
+                          (origin-uri (package-source f2fs-tools))))
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1m6bn1ibq0p53m0n97il91xqgjgn2pzlz74lb5bfzassx7159m1k"))))
+                "0wpzklw8smnngng0dm25jdmi7v5zfhpz02dksyxpz0a7kzzvnqqm"))))
     (inputs
      (list `(,util-linux "lib") libselinux))
     (arguments